macOSのターミナル上でgitのエラーが出てしまった場合の対処法

Pocket

macOSのメジャーアップデートをしたあとにターミナルでgitコマンドを使おうとすると次のようなエラーが出てしまいました。

$ git pull
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

developerのパスが無効ですと言われてしまっています。

CommandLineToolsをインストールして解決する

このエラーはCommandLineToolsをインストールして解決することができます。

CommandLineToolsのインストールはXcodeをインストールしても良いですがコマンドラインでxcode-select –installと実行することでもインストールすることができます。

iOSアプリの開発者とかでなければこちらの方が良いかもしれません。

$ xcode-select –install
xcode-select: note: install requested for command line developer tools
 

Pocket